2 had some facts about Emacs version 25 wrong, also clarified some text
source | link

I think this is related to some breaking changes in Emacs 25.0. A breakage which have been resolved in version 25.1 (which explains why uninstalling and reinstalling seems to have solved your problem).*

https://github.com/magnars/expand-region.el/issues/160

I'm still running 25.0.* and solved the problem by installing expand-region from MELPA where they have implemented a fix to workaround Emacs versions <= 25.0 > 2525+ has been implemented.1

TheNote: Do not use the version in MELPA stable (as of this writing version 00.10.0) DOES NOT WORK!in MELPA stable since it does not work.

I think this is related to some breaking changes in Emacs 25.0. A breakage which have been resolved in version 25.1 (which explains why uninstalling and reinstalling seems to have solved your problem).

https://github.com/magnars/expand-region.el/issues/160

I'm still running 25.0 and solved the problem by installing expand-region from MELPA where they have implemented a fix to workaround Emacs versions <= 25.0 > 25.1

The version in MELPA stable (as of this writing version 0.10.0) DOES NOT WORK!

I think this is related to some breaking changes in Emacs 25.0.*

https://github.com/magnars/expand-region.el/issues/160

I'm still running 25.0.* and solved the problem by installing expand-region from MELPA where a fix to workaround Emacs versions 25+ has been implemented.

Note: Do not use the version (0.10.0) in MELPA stable since it does not work.

1
source | link

I think this is related to some breaking changes in Emacs 25.0. A breakage which have been resolved in version 25.1 (which explains why uninstalling and reinstalling seems to have solved your problem).

https://github.com/magnars/expand-region.el/issues/160

I'm still running 25.0 and solved the problem by installing expand-region from MELPA where they have implemented a fix to workaround Emacs versions <= 25.0 > 25.1

The version in MELPA stable (as of this writing version 0.10.0) DOES NOT WORK!