Podcast #128: We chat with Kent C Dodds about why he loves React and discuss what life was like in the dark days before Git. Listen now.
2 [Edit removed during grace period]
| link
1
source | link

Please help me get emacsclient working

  • OS X 10.11
  • Emacs 24.5: /Applications/Emacs.app
  • emacsclient: /Applications/Emacs.app/Contents/MacOS/bin-x86_64-10_9/emacsclient
  • (server-start) in my .emacs file
  • % emacsclient some-file

Result is:

/Applications/Emacs.app/Contents/MacOS/bin-x86_64-10_9/emacsclient: can't find socket; have you started the server? To start the server in Emacs, type "M-x server-start".

/Applications/Emacs.app/Contents/MacOS/bin-x86_64-10_9/emacsclient: No socket or alternate editor. Please use:

--socket-name --server-file (or environment variable EMACS_SERVER_FILE) --alternate-editor (or environment variable ALTERNATE_EDITOR)

I have also tried this running Emacs and emacsclient as installed with MacPorts with the same result.

This is been happening for many years. I can't even remember the last time I was able to use emacsclient. I have searched extensively for information about this, but all I can find is information I already know as a sophisticated Emacs user of many decades.

I am not looking to run Emacs as a daemon.

Suggestions?