2 long press doesn't work in terminals, apparently
source | link

On linked text, such as what you find on the start page, left-clicking only moves the cursor and sets the active window like it normally does. To follow the link, you need to press the middle mouse button (that's the wheel if you have a two-buttons-and-a-wheel mouse), or do. Left-clicking does push proper buttons.

A a long press of the left mouse button (450ms by default). Left-clicking does push proper buttons also follows links, but I think that doesn't work in terminals.

If you want left clicks to always follow links regardless of duration, in the Customize interface, go to Editing → Mouse and change the setting of “Mouse 1 Click Follows Link” to enable it. Or put this in your init file:

(setq mouse-1-click-follows-link t)

If you want only double-clicks of the left button to follow links, set the variable to double instead of t. If you want to tune the minimum duration for a click to follow the link, set this to a number of milliseconds.

I don't know if that setting affects Neotree.

GUI Emacs tends to be more comfortable to work in than terminal Emacs. Instead of running Emacs on the remote machine, consider running Emacs locally and editing remote files.

On linked text, such as what you find on the start page, left-clicking only moves the cursor and sets the active window like it normally does. To follow the link, you need to press the middle mouse button (that's the wheel if you have a two-buttons-and-a-wheel mouse), or do a long press of the left mouse button (450ms by default). Left-clicking does push proper buttons.

If you want left clicks to always follow links regardless of duration, in the Customize interface, go to Editing → Mouse and change the setting of “Mouse 1 Click Follows Link” to enable it. Or put this in your init file:

(setq mouse-1-click-follows-link t)

If you want only double-clicks of the left button to follow links, set the variable to double instead of t. If you want to tune the minimum duration for a click to follow the link, set this to a number of milliseconds.

I don't know if that setting affects Neotree.

On linked text, such as what you find on the start page, left-clicking only moves the cursor and sets the active window like it normally does. To follow the link, you need to press the middle mouse button (that's the wheel if you have a two-buttons-and-a-wheel mouse). Left-clicking does push proper buttons.

A a long press of the left mouse button (450ms by default) also follows links, but I think that doesn't work in terminals.

If you want left clicks to always follow links regardless of duration, in the Customize interface, go to Editing → Mouse and change the setting of “Mouse 1 Click Follows Link” to enable it. Or put this in your init file:

(setq mouse-1-click-follows-link t)

If you want only double-clicks of the left button to follow links, set the variable to double instead of t.

I don't know if that setting affects Neotree.

GUI Emacs tends to be more comfortable to work in than terminal Emacs. Instead of running Emacs on the remote machine, consider running Emacs locally and editing remote files.

1
source | link

On linked text, such as what you find on the start page, left-clicking only moves the cursor and sets the active window like it normally does. To follow the link, you need to press the middle mouse button (that's the wheel if you have a two-buttons-and-a-wheel mouse), or do a long press of the left mouse button (450ms by default). Left-clicking does push proper buttons.

If you want left clicks to always follow links regardless of duration, in the Customize interface, go to Editing → Mouse and change the setting of “Mouse 1 Click Follows Link” to enable it. Or put this in your init file:

(setq mouse-1-click-follows-link t)

If you want only double-clicks of the left button to follow links, set the variable to double instead of t. If you want to tune the minimum duration for a click to follow the link, set this to a number of milliseconds.

I don't know if that setting affects Neotree.