The Stack Overflow podcast is back! Listen to an interview with our new CEO.
2 deleted 1150 characters in body
source | link

@ emlprime Jan 8 '15 at 19:12

So here too.

I found out, that neither

  1. that root (and the own username too) dosn't work. Oh no, thats not a bug, thats a (well hidden!) feature of the mysql-developers.

(Under Stalin such things would have beenroot nor my own username works. This is not a bug; it's a (mass-computer-) Sabotage and and the developers would have been sentenced to dead.well hidden!)

(You know, there are two different types of peoples in the world: normals and developers .. mysql feature.)

What worked for me:

A)So I added a new user in mysql with all root privileges, but with a different name than "root" - and voila - it works ---- sorry, not yet!!

Why?

I had no bearing at first.

What was helpful in this situation: Comment the wholefrom root.emacs - starting-file!

WowHowever, it worked then.

So I taked backthat alone didn't fix the comments line after line and voila! There was a littleproblem for me because I also had some code in my mysql-part,init file which called a mysql-BUFFER!!

Nice thing, you believe? Yes - if the right data are in this buffer, you never have to weit them again. BUT: If the wrong data are buffered there, you can input the right ones a thousand times - there always will be the wrong login-data instead - without warning(!) - and instead login you get: this worldwide well known error ...

so comment this partTo find and - maybe - it wil run then.

So it worked for me at the beginning 2018.

(sorry for my "english")

Jo

p.s. Those problems are persistent since over 10 years already - undocumentedremove that problematic code, no real solution - like you can see it easilyI commented out everything in internet -my init file and no onethen uncommented parts of the developers has changed it ... no questions anymore ... Like i sayd: There are two sides inuntil I found the world: normals and developers ..problem.

@ emlprime Jan 8 '15 at 19:12

So here too.

I found out,

  1. that root (and the own username too) dosn't work. Oh no, thats not a bug, thats a (well hidden!) feature of the mysql-developers.

(Under Stalin such things would have been (mass-computer-) Sabotage and and the developers would have been sentenced to dead.)

(You know, there are two different types of peoples in the world: normals and developers ...)

What worked for me:

A) I added a new user in mysql with all root privileges, but with a different name than "root" - and voila - it works ---- sorry, not yet!!

Why?

I had no bearing at first.

What was helpful in this situation: Comment the whole .emacs - starting-file!

Wow, it worked then.

So I taked back the comments line after line and voila! There was a little code in my mysql-part, which called a mysql-BUFFER!!

Nice thing, you believe? Yes - if the right data are in this buffer, you never have to weit them again. BUT: If the wrong data are buffered there, you can input the right ones a thousand times - there always will be the wrong login-data instead - without warning(!) - and instead login you get: this worldwide well known error ...

so comment this part and - maybe - it wil run then.

So it worked for me at the beginning 2018.

(sorry for my "english")

Jo

p.s. Those problems are persistent since over 10 years already - undocumented, no real solution - like you can see it easily in internet - and no one of the developers has changed it ... no questions anymore ... Like i sayd: There are two sides in the world: normals and developers ...

I found out that neither root nor my own username works. This is not a bug; it's a (well hidden!) mysql feature.

So I added a new user in mysql with all root privileges, but with a different name from root.

However, that alone didn't fix the problem for me because I also had some code in my init file which called a mysql buffer.

To find and remove that problematic code, I commented out everything in my init file and then uncommented parts of it until I found the problem.

1
source | link

@ emlprime Jan 8 '15 at 19:12

So here too.

I found out,

  1. that root (and the own username too) dosn't work. Oh no, thats not a bug, thats a (well hidden!) feature of the mysql-developers.

(Under Stalin such things would have been (mass-computer-) Sabotage and and the developers would have been sentenced to dead.)

(You know, there are two different types of peoples in the world: normals and developers ...)

What worked for me:

A) I added a new user in mysql with all root privileges, but with a different name than "root" - and voila - it works ---- sorry, not yet!!

Why?

I had no bearing at first.

What was helpful in this situation: Comment the whole .emacs - starting-file!

Wow, it worked then.

So I taked back the comments line after line and voila! There was a little code in my mysql-part, which called a mysql-BUFFER!!

Nice thing, you believe? Yes - if the right data are in this buffer, you never have to weit them again. BUT: If the wrong data are buffered there, you can input the right ones a thousand times - there always will be the wrong login-data instead - without warning(!) - and instead login you get: this worldwide well known error ...

so comment this part and - maybe - it wil run then.

So it worked for me at the beginning 2018.

(sorry for my "english")

Jo

p.s. Those problems are persistent since over 10 years already - undocumented, no real solution - like you can see it easily in internet - and no one of the developers has changed it ... no questions anymore ... Like i sayd: There are two sides in the world: normals and developers ...