4

This is how I attempted to install the package:

I ran the command list-packages and then tried to install the auctex package in package mode. This was the line showing auctex entry in package mode:

  auctex             11.88.2      available  gnu        Integrated environment for *TeX*

Now when I try to install that, I get this message:

package--check-signature: Failed to verify signature auctex-11.88.2.tar.sig: ("Bad signature from 474F05837FBDEF9B GNU ELPA Signing Agent ")

How do I fix this ? Any other method to install auctex is also welcome.

  • In addition to ELPA and source code, you can also install it via your OS's package manager if possible. – xuchunyang Mar 16 '15 at 12:25
  • When I have trouble installing from list-packages, the first thing I try is to start emacs fresh with a minimal version of my init file. Sometimes there are conflicts with active packages... but I have no idea if that's what this error could be from. – Brian Z Mar 16 '15 at 12:30
  • 2
    That looks like a serious problem that should be reported via M-x report-emacs-bug. – Stefan Mar 16 '15 at 12:42
  • Do you have the following line in your .emacs? (setq-default coding-system-for-read 'utf-8) If so, try removing it, restarting emacs and installing the package. It seems there is some problem with gnupg, package.el and emacs when coding system is set to utf8. – Iakov Davydov Oct 10 '17 at 15:27
  • If you can reproduce the problem, please report it via M-x report-emacs-bug, because it really should not happen. – Stefan Sep 2 '18 at 21:01
4

I just installed it from source:

  1. get the source code: http://www.gnu.org/software/auctex/download.html

  2. build:

    ./configure --prefix=$HOME/.emacs.d/site-lisp/auctex --with-lispdir=$HOME/.emacs.d/site-lisp/auctex --with-texmf-dir=$HOME/.local/lib/texmf
    make
    make install
    

    (this builds auctex for a user and doesn't require superuser privilages)

  3. load to emacs:

    (add-to-list 'load-path "~/.emacs.d/site-lisp/auctex")
    (load "auctex.el" nil t t)
    (load "preview-latex.el" nil t t)
    

That's it: calling M-x latex-mode then loads auctex.

  • Thanks, just curious to know if package-mode method worked for you ? – Sibi Mar 16 '15 at 12:25
  • Last time I had been installing auctex (about 2 years ago) it has been working. In that time I used package-install specially to test the system. Currently I'm not using package-install and prefer to install el libraries from source. – Adobe Mar 16 '15 at 12:29
0

On a Debian-based linux system I used

sudo apt-get install auctex

at the command prompt in a terminal and that did the necessary. This should work on Ubuntu and other Debian based linux systems.

Of course, I had previously used

sudo apt-get install emacs  

I know that this is a late answer, but here just in case it might help someone as

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.