I am trying to display images in org files. I have used links such as


When I click on the link, it gives me another buffer in which there are only symbols. When I put the cursor on the link and type C-c C-x C-v, there is an error message in the minibuffer saying

No images to display inline

I tried to enable iimage-mode but it didn't work either. So, I wonder if there is a problem with the org version installed with Emacs (I am using Emacs 24.4 with Org 8.2.10 and I am on Windows) or is there any configuration that I should do?

  • Have you tested this with, say, a jpg image? Sometimes png support is a little fiddly. Commented Mar 18, 2015 at 18:45
  • Works fine for me.. I started an emacs -Q session, M-x org-mode, [[file:~/path/to/image.png]] (with path pointing to an actual .png) and C-c C-x C-v. I am on latest emacs build from git, built with imagemagick on RHEL 5. org-mode is the latest available on Melpa. Commented Mar 18, 2015 at 18:57
  • @MatthewPiziak, I just tried with a jpg image. It's the same problem.
    – aymenbh
    Commented Mar 18, 2015 at 18:59
  • @kaushalmodi, I tried the manipulation on two different computers, same result. I downloaded Emacs a few weeks ago. Which version of org-mode do you have?.
    – aymenbh
    Commented Mar 18, 2015 at 19:02
  • 1
    Windows is the key here, you don't have the necessary libraries for displaying images. I've got a couple different Emacs distros on my Windows box at the moment, and can only display pngs using the one obtained here: bitbucket.org/Haroogan/emacs-for-windows
    – glucas
    Commented Mar 18, 2015 at 19:32

4 Answers 4


In addition to the above points there is one more detail. If clicking the link displays the image correctly in a new buffer, but toggling org-display-inline-images returns the message No images to display inline, you may have description text in the link: [[path_to_image][description]]. Remove the description, leaving only [[path_to_image]], and the images should display inline correctly.

As explained in the org manual:


C-c C-x C-v (org-toggle-inline-images) Toggle the inline display of linked images. Normally this will only inline images that have no description part in the link, i.e., images that will also be inlined during export. When called with a prefix argument, also display images that do have a link description. You can ask for inline images to be displayed at startup by configuring the variable org-startup-with-inline-images.

Does anyone know the prefix for displaying inline images that have description text?

  • 1
    It's the ordinary prefix key, C-u.
    – Tom Davey
    Commented Oct 7, 2022 at 15:28

Just in case anybody had already downloaded the PNG DLL and they still get the

No images to display inline

message, [[Z:\test.png]] collapses down, but running org-toggle-inline-images does not expand it into an image. However [[file:Z:\test.png]] does. Note that the file: part is important.

BTW - I downloaded my PNG dll from https://sourceforge.net/projects/ezwinports/files/, but Vincent Goulet's distribution mentioned above seems like a good idea.

  • This one helped me. :) Thanks!
    – radekg
    Commented Mar 28, 2021 at 15:55

Emacs for Windows is generally not distributed with the necessary libraries to display PNG and other image formats. See this section of the GNU Emacs FAQ for MS Windows.

The easiest solution is to install an Emacs distributions for Windows that is built with image support, such as this one.

Alternatively you can add the necessary libraries. See this question on Stack Overflow.

  • I just downloaded the distro. It works fine when I click on the link for jpg images but not for png images. For these, I get a small black box with white borders. But it does not work for C-x C-c C-v nor M-x org-display-inline-images. I get the same results as above.
    – aymenbh
    Commented Mar 18, 2015 at 19:55
  • Interesting, I tested it with a png file. (I had been pointed to this specific distro a while back for problems with another image format.) I may have some other libraries on the exec path or something -- I'll take a closer look.
    – glucas
    Commented Mar 18, 2015 at 21:35
  • 1
    The distribution by Vincent Goulet has the *.dll files needed: vgoulet.act.ulaval.ca/en/emacs "This version of Emacs bundles the libraries needed to display images in formats XPM, PNG, JPEG, TIFF and GIF supported Windows since Emacs version 22.1. Among other things, this means that the toolbar displays in color, that the ESS toolbar displays correctly and that the preview-latex mode of AUCTeX works to its full extent. However, the latter requires to separately install Ghostscript and to make sure that the file gswin32c.exe is in a folder along the PATH environment variable."
    – lawlist
    Commented Mar 19, 2015 at 0:31
  • @glucas I tried it again on my computer at the office, it works just fine for both jpg and png images. I may have something missing in my other computer at home. However, it works only when I click on the org-link, not when I use C-x C-c C-v. Besides (when it works), it shows the images on a new buffer. Is there a way to show it on the same buffer as the link?
    – aymenbh
    Commented Mar 19, 2015 at 8:39
  • 1
    This was working perfectly with Emacs 24.3. I just upgraded to Emacs 25.1 and nothing is working anymore. All the DLLs that were working with 24.3 are in /bin/ but (image-type-available-p 'png) still return nil even if (print image-library-alist) shows that the right file is handled. Any ideas why this is not working anymore in Emacs 25.1?
    – Neoasimov
    Commented Nov 7, 2016 at 20:38

Based on manual, provided by Snelephant's answer If your image also contains a description on the link, then you should use:

C-u C-c C-x C-v
  • Should be a comment on the mentioned answer. perhaps it could be addressed by a moderator or expanded to be legible as an answer in its own right. Commented Apr 1, 2019 at 16:02
  • I tried to put is as a comment, but it required that I have 50+ reputation. And I don't think that there's more to add,so to expand it more would be repeating what was already said.
    – gekaklam
    Commented Apr 3, 2019 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.