I was editing some code in an Emacs client, when all of a sudden it stopped reacting to my input. If I killed the client and connected with a new one, I got a pretty strange behaviour:

  • if I tried to open a file that has changed (due to git rebase operations in another terminal), Emacs warned me about this and asked me if I wanted to re-read the buffer’s file. It accepted and displayed my input in the minibuffer. After that it presented me an empty window, and stopped reacting
  • if I tried to open any other file/directory, I got the same empty window with no reaction again
  • if I opened an X-Windows version of Emacs client with any file, I got the same result. Furthermore, the menu items didn’t react to clicking and the X window didn’t react to its close button, Alt-F4, etc.

After this point, nothing happened. The minibuffer and all the other windows didn’t update, any input seemed to be discarded (C-x C-c, M-x, whatever).

1 Answer 1


While I was writing this post I tried to simply press C-g if some background operation is in progress I am not aware of, and I got control back.

It turned out that company-mode hung somewhere. I was editing some Python code with a running Python instance (started with M-x run-python).

  • 1
    If you find a way to reproduce this, M-x toggle-debug-on-quit in advance, and after C-g you should have a nice backtrace you can paste into a bug report.
    – Dmitry
    Apr 25, 2015 at 14:08
  • Please accept your own answer if you're satisfied with it so that it will be marked as accepted.
    – Dan
    Apr 25, 2015 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.