3

I'm using Classic Console font in buffers. Unfortunately for some reason letter spacing is terrible in Emacs while being correct in Konsole and other programs.

Text in Emacs: Classic Console in Emacs

Text in Konsole (using the same font and size): Classic Console in Konsole

Any idea how to fix this?

Another case with Courier Prime:

enter image description here

'(default ((t (:family "Courier Prime" :foundry "QUQA" 
               :slant normal :weight normal :height 83 
               :width normal :spacing 10))))

:spacing 10 did not work.

6
  • What exactly font used in Emacs? Type C-u C-x = on any character. Compare with xlsfonts -fn '*-*-*-*-*-*-*-*-*-*-*-m*' or fc-list :spacing=mono like commands.
    – gavenkoa
    Commented Apr 2, 2015 at 19:56
  • I have filling that in Konsole you use 13px font, but 12px in Emacs.
    – gavenkoa
    Commented Apr 2, 2015 at 19:58
  • How are you setting the font? Note the emacs sample use lots of different faces, some bold. If these have different width to regular letters then you will see uneven spacing. Commented Apr 10, 2015 at 7:06
  • 1
    I had the same issue and fixed it for the font called "Hack". All it took was to set the font spacing. (set-default-font "Hack-11:spacing=110") or in your case: (set-default-font "Classic Console-11:spacing=100") Commented Oct 23, 2015 at 2:50
  • @PedroPenna, that didn't work for me; I've put (set-default-font "Courier Prime:spacing=10")
    – Necktwi
    Commented Sep 17, 2019 at 15:46

1 Answer 1

1

10 is not a valid spacing, try: 90 dual or 100 mono.

Eg:

'(default ((t (:family "Courier Prime" :foundry "QUQA" 
               :slant normal :weight normal :height 83 
               :width normal :spacing 90))))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.