0

The cedet info I am using with emacs 23.4.1

ECB 2.40 uses CEDET 1.0 (contains semantic 2.0, eieio 1.3, speedbar <unknown version>).

I am trying to create a cpp-root-project for out-of-source-tree building, however, when I try to create a project definition using

(ede-cpp-root-project "project-root"
                      :file "~/dev/gorgon/build/dummy-makefile"
                      :include-path '("/Source")
                      ;:system-include-path '("~/linux")
)

by requiring the file containing above code to load with

(require 'projects)

it gives following error

Symbol's function definition is void : ede-cpp-root-project

at first I thought maybe this "feature" is lacking so I tried to list available projects from ede projects and it listed

Automake
make

My question is does this functionality supported in CEDET 1.0 or am I doing something wrong?

the codes related to ede in my init.el file

(global-ede-mode 1)
(semantic-mode 1)
(ede-enable-generic-projects)
(global-semantic-idle-scheduler-mode)
(global-semantic-idle-completions-mode)
(global-semantic-decoration-mode)
(global-semantic-highlight-func-mode)
(global-semantic-show-unmatched-syntax-mode)
  • Welcome. Does the error message really have the final s? – Andrew Swann Apr 13 '15 at 12:18
  • It was a mistake. 's' does not belong to error message. – Cengiz Kandemir Apr 13 '15 at 14:00
  • (require 'ede/cpp-root) or something ? – politza Apr 13 '15 at 19:54
  • tried both (require 'ede/cpp-root) and (require 'ede/cpp-root-project) just to be sure. I get error: file for ede-cpp-root must be a file for the former; can not open load file for the latter. Not sure if relevant but I did not install CEDET from its repo. I think I am using built-in version. – Cengiz Kandemir Apr 13 '15 at 20:39
  • The :file argument must be a existing directory. – politza Apr 15 '15 at 19:12
0

According to the Commentary: for../ede/ede-cpp-root.el`, the file should only be the FILENAME and not a path. Try changing to

(ede-cpp-root-project "project-root"
                  :file "dummy-makefile"
                  :include-path '("/Source" "~/dev/gorgon/build")
                  ;:system-include-path '("~/linux")
 )

cedet-1.1 is very old. Try updating to cedet-2.0.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.