4

My situation is similar to Info file emacs does not exist. I installed emacs24, emacs24-el, and emacs24-common-non-dfsg on Ubuntu 14.04. Unlike in that other question, C-h r does work for me and I do get the "Emacs" manual.

However from using Emacs on OS X, I'm accustomed to C-h i bringing up a full directory of many, many topics. Instead, my directory only has three nodes, for a few packages that provide info files (Flycheck, Haskell Mode, and Magit).

(Info-default-dirs) evaluates to ("/usr/share/info/emacs-24" "/usr/share/info/" "/usr/share/info/"). I do see all the individual info.gz files in /usr/share/info/emacs-24. I can open them individually, for example (info "/usr/share/info/emacs-24/elisp.info.gz") does bring up the "Emacs Lisp" node.

But again, I'm accustomed to C-h i bringing up the full directory. I don't know much about info files. How can I make this work?

  • What is the value of Info-directory-list? – rekado Apr 21 '15 at 5:29
  • 1
    If you run info from the command line, do you get the same result? – Jenny D Apr 21 '15 at 7:43
  • @rekado It's ("/home/greg/.emacs.d/elpa/flycheck-20150412.242" "/home/greg/.emacs.d/elpa/haskell-mode-20150412.1138" "/home/greg/.emacs.d/elpa/magit-20150411.1731" "/usr/share/info/emacs-24" "/usr/share/info/" "/usr/share/info/") – Greg Hendershott Apr 21 '15 at 14:42
8

It sounds as if the dir file within your info directories don't contain all the nodes that it should. You can verify this by looking at the contents of the file /usr/share/info/emacs-24/dir (if this is the directory that's lacking entries).

Normally, this file will be updated by the program that installs the info file, but you can also do it manually. If the info directory that is missing entries is /usr/share/info/emacs-24, you can create the dir entries by running

cd /usr/share/info/emacs-24
for i in *info*; do install-info $i dir; done
  • Thanks! /usr/share/info/emacs-24 lacked any dir file. Also, install-info wasn't found. (If it had been, maybe the apt-get install emacs-24-common-non-dfsg would have updated the dir.) I installed the info package, followed your instructions, and now all is well. (p.s. This is Ubuntu from crouton on a Chromebook. I'm realizing the initial config is fairly minimal. On the bright side, I'm learning more. :)) – Greg Hendershott Apr 21 '15 at 14:42
  • I'm glad it worked! – Jenny D Apr 21 '15 at 14:53
6

C-h i runs the info command by default, which searches for info files in Info-directory-list. If this is nil Info uses the environment variable INFOPATH or Info-default-directory-list if no INFOPATH variable is defined.

When the info files are not found it is possible that one or more of these values has been incorrectly customised.

  • You can also add paths to Info-additional-directory-list. – GDP2 May 23 '18 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.