3

I have

'(TeX-insert-braces nil)

in my customizations, which according to the document should mean that braces {} are not automatically inserted after macros via TeX-insert-macro. However, when I insert the accent macro \tilde the braces are added, contrary to my wish.

I can trace this down to latex.el containing

   (TeX-add-symbols
    ...
    '("tilde" t)
    ...
   )

in the function LaTeX-common-initialisation. As a result I have tried to override the setting by adding

(TeX-add-symbols '("tilde" nil))

to my 'LaTeX-mode-hook, but this doesn't work.

How do I do this and is there a systematic way to implement this for all accent symbols?

Note the list of such symbols is available in the Math > Accents menu, when math mode is enable (which I do by default).

1

If you don't want braces at all use 0 as argument specification:

(TeX-add-symbols '("tilde" 0))

See the documentation of TeX-add-symbols:

...

number

Insert that many braces, leave point inside the first. 0 and -1 are special. 0 means that no braces are inserted. -1 means that braces are inserted around the macro and an active region (e.g {\tiny foo}). If there is no active region, no braces are inserted.

...

| improve this answer | |
  • +1 this works fine in the hook. It is frustrating that C-h f TeX-add-symbols` does not provide this information. Anyway, any ideas about doing this systematically for all (math) accents? – Andrew Swann Apr 23 '15 at 10:45
  • How about a dolist over all accent macros? TeX-add-symbols description isn't really detailed because it's autogenerated by a macro. – giordano Apr 23 '15 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.