2

I am running Ubuntu 14.04. I don't use emacs from its repository.

I installed my emacs by compling from source, the default location is /usr/local. e.g. /usr/local/bin/emacsand /usr/local/share/emacs/24.4/.

I installed ESS from its offical site. The default install location is /usr e.g. /usr/share/emacs/. I don't find a way to specify --prefix for ESS. I run make install directly.

So in my emacs, I can't find S mode.

What shall I do?

Shall I reinstall emacs with ./configure --prefix=/usr? Generally speaking, should installation from source be in /usr or /usr/local?

Thanks!

  • Either reinstall ESS and tell it to use your preferred directory, or else add ESS's directory to your loadpath. – Dan Apr 22 '15 at 22:07
  • I don't find a way to specify --prefix for ESS. I run make install directly. – Tim Apr 22 '15 at 22:18
  • You can always use (load "path/to/ess-site") but the default location should be checked by any emacs, built from source or not. Have you done (load "ess-site") first? (ESS is a bit old fashioned). – VitoshKa Apr 22 '15 at 22:45
  • Correction: Ubuntu default instal checks /usr/local/ but the one built from source does not. – VitoshKa Apr 22 '15 at 22:55
  • @VitoshKa: Thanks (1) What do you mean by ess-site? I have three files with that name: /usr/share/emacs/site-lisp/ess-site.el /usr/share/emacs/site-lisp/ess/ess-site.el /usr/share/emacs/site-lisp/ess/ess-site.elc. (2) What do you mean by "Ubuntu default instal checks /usr/local/ but the one built from source does not"? and are you talking about ESS? – Tim Apr 22 '15 at 23:02
2

One easy option is to change the default DESTDIR directly in the Makeconf.

2

You can try downloading the ESS tgz file, unpack it in a directory of choice (for example, I put it in .emacs.d) and then add

(load "~/.emacs.d/ess-15.09-2/lisp/ess-site")

to your .emacs file. No need to recompile anything in this way.

  • Compiling is optional but reference documentation is not available – par Jan 12 '17 at 10:11
  • But where is that .emacs file that you add this text to? – Clark Henry Dec 3 '17 at 6:32
  • 1
    @ClarkHenry the .emacs file (also called init file) is always in your home directory – rs028 Dec 28 '17 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.