I occasionally have the problem that the character to the right of my point starts blinking. Can anyone think of anything that could be causing this problem?

enter image description here

  • 4
    The best way to debug this would be to start up emacs -Q and enable your customizations one by one until you see which one causes the problem. Also it would be helpful to know all the minor modes you have active. Use describe-mode to get a list. Commented May 1, 2015 at 15:49
  • That's a very good point. I'll post with an EDIT once I've debugged more of the problem. Thanks.
    – Mike H-R
    Commented May 1, 2015 at 15:51
  • 4
    This is a known phenomenon caused when Emacs has too many timers active with small intervals. A known package exhibiting this problem would be popwin. If you have helm installed, you can view these with M-x helm-timers.
    – wasamasa
    Commented May 1, 2015 at 16:16
  • @wasamasa is that phenomenon a bug or a feature?
    – PythonNut
    Commented May 1, 2015 at 16:57
  • Looks like a font-lock bug to me, but still, this timer situation shouldn't happen in the first place.
    – wasamasa
    Commented May 2, 2015 at 7:13

1 Answer 1


Emacs comes with a timer feature that allows you to run a function in periodical intervals. Some packages abuse this feature by setting their timer intervals very low (around 0.01s) and use it for polling, if they don't manage cleaning up the timers after themselves and leave spurious ones in the timer-list, one after-effect is flickering of letters after point in syntax-highlighted buffers (the other one is more wakeups/CPU usage than necessary).

To check up whether that's the cause of your problem, inspect this timer list with F1 v timer-list (or with M-x helm-timers if you've got helm installed) and see whether it contains repeated entries that can be traced back to a specific package. I used to have such problems with the Auto-Complete, popwin and helm packages (though, helm seems to have finally fixed it, I've migrated from Auto-Complete to company-mode). Either get the packages themselves fixed (be it by handing in a pull request or submitting a ticket on their issue tracker), write better ones (what I did with popwin in favour of shackle) or just abstain from them completely.

  • I found removing the flymake configuration from my .emacs and using flycheck instead removed the cause of this problem for me. Commented Aug 7, 2015 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.