4

I use subword-mode when I'm editing Python and C++ code, and it's jarring when deleting a word backwards/forwards (Ctrl+Space and Ctrl+Delete) works one way in the source code buffer and a different way when I'm in the minibuffer. Is there a way to make it consistent? I've never tried having a minor mode active in a minibuffer before.

4

You can enable the subword mode in the minibuffer by adding the below to your emacs init.

(add-hook 'minibuffer-setup-hook #'subword-mode)

The same applies for any hook and minor mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.