2

So I've been trying to learn and use both Emacs and Org-mode for a while and it has been going pretty well but I am certainly a beginner in these topics including Emacs Lisp.

I found this really good-looking org package called org-drill and I've been struggling to get it running. I initially tried what it said in the installation manual, as in changing the org default variables and ticking the box where it says dril... that didn't work. I tried googling for a bit and I figured that maybe I don't have contrib packages installed. I tried doing what was given as the answer here: org-plus-contrib and org with `require` or `use-package` again, to no avail. I tried manually searching for the package org-plus-contrib and I couldn't find it. In my init.el I have this:

;; ELPA
(setq package-user-dir (concat dotfiles-dir "elpa"))
(require 'package)
(dolist (source '(("melpa" . "http://melpa.org/packages/")
              ("marmalade" . "http://marmalade-repo.org/packages/")
              ("org" . "http://orgmode.org/elpa/")
              ("elpa" . "http://tromey.com/elpa/")))
  (add-to-list 'package-archives source t))
(package-initialize)

So as I said, installing org-plus-contrib doesn't work. Neither does manually searching for it. Is it already installed? Am I missing something? Requiring org-drill in any manner doesn't work either. Do I have to manually include the contrib folder? I tried searching where it is but that didn't work either. I'm just not sure where to look next. Any suggestions would be brilliant.

Thanks a lot.

  • 1
    This question is poorly posed, and so risks being closed as unclear. You say nothing about what you have tried specifically, what you expected, and what specifically you saw happen instead. If you want helpful help then you owe it to yourself to provide the best possible description of the problem, which means providing specifics - in this case probably a step-by-step recipe of what you did. – Drew May 3 '15 at 23:08
  • Sorry, I was pretty frustrated when I wrote that. But yes, I'll edit it now, I should know better. Thanks for the reply. – phunkrebel May 4 '15 at 0:45
  • 1
    What error message does (require 'org-drill) give you? – erikstokes May 4 '15 at 1:59
  • What happens when you do M-x find-library RET org-drill RET? – itsjeyd May 4 '15 at 6:34
  • Check you directories under ~/.emacs.d/elpa. If you have sucessfully installed org-plus-contrib there should be directory starting with name and containing org-drill.el. It is best if you have no other package installation of org mode present. – Andrew Swann May 4 '15 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.