4

Using my prelude-based emacs install full-screen on my laptop, I normally have 2 vertical windows side-by-side. If I invoke helm-mini, it normally takes up half of one vertical window, so about a quarter of my laptop screen. However when it's showing the full path of recent files, these trail off the right edge of the helm window, hiding the useful file name:

enter image description here

I know I can hit C-t a few times to move the helm window around, and hopefully get a winder window that can hopefully show the file name, but that's cumbersome.

Is there a setting or feature that will help here? Maybe truncating the left side of the line, not the right? Or wrapping the line around? Or something else?

  • You can use C-] to shorten the paths in recentf source, so Helm entries don't expand the whole screen. Also, disable linum-mode in Helm might help. – Tu Do May 20 '15 at 12:46
  • C-] is a decent hack. Main drawback is that it only works for the current section of helm-mini; so if the cursor is in Buffers, it doesn't shorten recentf. Would still like something automatic. – tenpn May 20 '15 at 12:49
  • You can set (setq helm-truncate-lines nil) to avoid truncating the lines. Alternatively, you can use helm-buffers-list and (setq ido-use-virtual-buffers t) to enable visited files to be displayed in helm-buffers-list. Choose one depends one whether you want to see the full paths or not. – Tu Do May 20 '15 at 13:25
  • helm-truncate-lines is already nil for me. maybe something else is going on? – tenpn May 20 '15 at 13:35
  • That's right. It has no effect. I used this code instead: (add-hook 'helm-after-initialize-hook (lambda () (with-helm-buffer (visual-line-mode)))). – Tu Do May 20 '15 at 13:40
8
+50

To wrap the entries in Helm buffer instead of truncating them, add function to helm-after-initialize-hook:

(add-hook 'helm-after-initialize-hook (lambda ()
                                        (with-helm-buffer
                                          (visual-line-mode))))

Alternatively, you can use helm-buffers-list and add this setting: (setq ido-use-virtual-buffers t) to enable visited files to be displayed in helm-buffers-list. Choose one depends one whether you want to see the full paths or not.

0

Take a note that for now. You can use:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.