1

When I open my emacs 24.4, I get:

Warning (emacs): Unable to activate package `emacs-eclim'.
Required package `s-1.9.0' is unavailable

but If I open version 24.1 there is no such error. eclim works pretty fine in both version, why it is happening ?

Note: I had a warning in version 24.4 which is:

Warning (initialization): Your `load-path' seems to contain
your `.emacs.d' directory: ~/.emacs.d/
This is likely to cause problems...

and I disabled it.

If this warning is connected with eclim warning somehow, better know it.

Why am I getting these warnings in version 24.4 ?

Thanks in advance...

4

Might be that the package "s" was removed from emacs default packages or that you had it somehow installed on the previous version. The package is available on the melpa repository.

Try this in your init.el (.emacs)

(require 'package)
(add-to-list 'package-archives
             '("melpa" . "http://melpa.org/packages/") t)
(package-initialize)

Then use M-x list-packages. Find the package named "s", type i (mark for installation), then x (execute). This will install the proper package and you should'n have the "is unavailable" message anymore.

  • you were right, this version cannot locate s.el somehow, I add-to-list to somewhere else and its fine anymore, thank you for your attention. – Vivian Maya May 20 '15 at 14:09
  • 1
    s.el was never a built-in package. It's possible that the warning is absent from 24.1 because 24.1 (a) just doesn't warn about this or (b) doesn't try to activate that package at startup. – Malabarba May 20 '15 at 17:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.