There is an annoying quirk of my minibuffer. Can you help me trace its origin?

Typing into the minibuffer causes it to instantaneously resize to 2 or 3 lines in height, and then back to 1 line. It happens far too quickly to take a screenshot. Best guess is it is a side effect of minibuffer autocompletion.

Do minor modes in other buffers, like Yas and AC, apply to the minibuffer? I thought not.

Thanks for your time!

1 Answer 1


Set resize-mini-windows to nil:

(setq resize-mini-windows nil)

You can also customize option max-mini-window-height, to let it resize but limit how much it grows.

See the Emacs manual, node Minibuffer Edit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.