2

Writing Greek in emacs is proving to be quite inconvenient. If my keyboard is set to Greek, normal shortcuts do not work and I have to switch to latin just to navigate around the buffer.

As an example, let's say I'm writing a Greek sentence and I want to go back a character to fix a mistake. The usual way is to press C-b, but because my keyboard is set to Greek, emacs actually receives C-β and gives me an error: "C-β is undefined". What I have to do next is press alt-shift to switch to latin, enter C-b again, and switch to Greek once again with alt-shift. Quite a hassle.

Is there a way around this? I could, of course, map C-β to do what C-b does, but I'd have to do that for hundreds of shortcuts.

It'd be nice if the solution worked for evil-mode, too.

2

This can be achieved by setting the input method of emacs.

The OS keyboard will remain set to English, but the latin keystrokes received by emacs will be re-interpreted to Greek ones. This will only happen when inserting text. Therefore, both emacs and evil-mode shortcuts will work properly even when the input method is set to Greek.

Adding the following to .emacs enables us to use C-\ to toggle entering text in Greek.

(set-input-method "greek")

If C-\ is inconvenient to type, it can be changed using global-set-key, ie

(global-set-key (kbd "C-c C-o") 'toggle-input-method)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.