I've set up MPD, and it's definitely running and indexing everything correctly. I followed the instructions here to set up EMMS to work with MPD, and after running M-x emms-cache-set-from-mpd-all, it indexed the right number of tracks, and connecting via emms-player-connect seems to work without error. However, when I call M-x emms, all I see is an empty window. What am I missing?

For reference, this is my config:

(require 'emms-player-mpd)
(require 'emms-setup)
(setq emms-player-mpd-server-name "localhost")
(setq emms-player-mpd-server-port "6600")
(add-to-list 'emms-player-list 'emms-player-mpd)
(add-to-list 'emms-info-functions 'emms-info-mpd)
  • If you try (emms-all) in place of (emms-standard), does that fix it?
    – Brian Z
    May 24, 2015 at 9:14
  • @BrianZ Nope - still get nothing in the window. I even tried (emms-devel) for good measure.
    – Koz Ross
    May 25, 2015 at 2:40
  • Personaly I used mingus, it works great. Jul 24, 2017 at 10:27

2 Answers 2


I don't think emms is what you want. Try following the instructions in the emms manual carefully, ending up at emms-smart-browse.


Unless your MusicPD is configured to use absolute file names, you must set the emms-player-mpd-music-directory variable to the value of "music_directory" in your MusicPD configuration.

Add for example as follows:

(setq emms-player-mpd-music-directory "~/Music/")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.