4

I'm trying to use EMMS with mplayer as its backend. So far, everything works fine, but for some reason, EMMS refuses point-blank to play anything with a .flac extension in my playlist. I've checked the regex EMMS uses for mplayer, and .flac is a viable extension for it. What could be causing this?

For reference, here is my EMMS config:

;;EMMS
(require 'emms-setup)
(require 'emms-streams)
(require 'emms-librefm-stream)
(require 'emms-librefm-scrobbler)
(emms-devel)
(emms-default-players)
(setq emms-source-file-default-directory "~/Music/")
(setq emms-librefm-scrobbler-username "Chuck_Finley") ;not my real name
(setq emms-librefm-scrobbler-password "tequila-miami") ;not my real password
(emms-add-directory-tree "~/Music/")
  • 2
    Quick sanity check: you can play flac files via mplayer on the command line, yes? – Dan May 30 '15 at 6:29
  • @Dan Yes, mplayer from the command line works without any issues. – Koz Ross May 30 '15 at 12:42
3
+50

Since it can be helpful to start with a minimum working example, please see if this works for you. It should help debug any other features of your setup that are causing breakage.

emacs -Q --load emms-init.el and then M-x emms-play-directory RET ~/Music RET, where emms-init.el is as follows, and where ~/Music/ contains the 0.4 MB .flac test file downloaded from http://www.linnrecords.com/linn-downloads-testfiles.aspx. My mplayer is MPlayer2 2.0-728-g2c378c7-2ubuntu3. With all of this in place I hear an annoying but brief tone.

(package-initialize nil)
(setq package-enable-at-startup nil)
(add-to-list 'package-archives '("org" . "http://orgmode.org/elpa/") t)
(unless (assoc-default "melpa" package-archives)
  (add-to-list 'package-archives '("melpa" . "http://melpa.org/packages/") t)
  (package-refresh-contents))

(unless (package-installed-p 'use-package)
  (package-install 'use-package))

(setq use-package-verbose t)
(require 'use-package)

;;EMMS
(use-package emms
  :ensure t :defer t
  :config
  (progn
    (require 'emms-player-simple)
    (require 'emms-source-file)
    (require 'emms-source-playlist)
    (require 'emms-player-mplayer)
    (setq emms-player-list '(emms-player-mplayer))
    (setq emms-source-file-default-directory "~/Music/")
    (emms-add-directory-tree "~/Music/")))
  • That seems to work fine. – Koz Ross May 31 '15 at 0:59
  • 1
    Great, if you feel that that solves the problem, please accept the answer, otherwise, if you would like a bit more help tracing the error, please convert the working example into a not-working example with a similar format and update your question :-] – Joe Corneli May 31 '15 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.