Where can I find pre-built Emacs for what Ubuntu calls emacs 25.1?

4 Answers 4


In addition to what abo-abo suggests, you can also build the sources by yourself:

git clone git://git.savannah.gnu.org/emacs.git
cd emacs
sudo apt-get build-dep emacs24 # for rpm-based linux: sudo yum-builddep emacs
./configure                    # if there's no configure script: ./autogen.sh
make                           # if that fails: make bootstrap
sudo make install
make clean
  • 3
    The OP asked “pre-built” binaries.
    – user227
    May 28, 2015 at 16:05
  • Is the git repo pointing at times to unstable versions? Shall I go with it or keep it safe and Use abo-abo's PPA ?
    – turbopape
    May 28, 2015 at 16:06
  • 1
    Yes, lunaryorn, I just added another option to what abo-abo said. May 28, 2015 at 16:07
  • 3
    I've been running Emacs 25 on one of my laptops, and I've found that it's rock solid when it builds. (It failed to build once, which was fixed within 20 minutes.) Definitely a good choice if you don't need the Debian/Ubuntu integration of the stock packages.
    – jch
    May 28, 2015 at 20:28
  • 6
    before ./configure I had to do ./autogen.sh otherwise the out line approach works(tm) Apr 24, 2016 at 20:19

Use the snapshot:

sudo add-apt-repository -y ppa:ubuntu-elisp
sudo apt-get update
sudo apt-get install emacs-snapshot

Stable versions (25.1 currently):

sudo apt-add-repository -y ppa:adrozdoff/emacs
sudo apt update
sudo apt install emacs25

Provided packages for LTS 14.04 and 16.04.

  • When I try this on LTS 14.04, I got this error: The following packages have unmet dependencies: emacs25 : Depends: emacs25-bin-common (= 25.1-trusty~ppa2) but it is not going to be installed I followed some dependency chains and then tried sudo apt-get install emacs25 emacs25-bin-common emacs25-common emacsen-common emacs25-el but got this error: The following packages have unmet dependencies: emacs25-common : Depends: emacsen-common (>= 2.0.8) but 2.0.8~trusty1 is to be installed I'm not sure what to try next.
    – Chris
    Dec 20, 2016 at 17:59
  • @Chris, try to solve today. Unfortunately, I have no ability for native run it on 14.04 :-(
    – Monah Tuk
    Dec 20, 2016 at 23:14
  • Hmm, seems that 2.0.8~trusty1 is less that 2.0.8
    – Monah Tuk
    Dec 20, 2016 at 23:39
  • @Chris, try to update now.
    – Monah Tuk
    Dec 21, 2016 at 0:21

For those who want to run stable emacs 25.1 on Ubuntu 16.10, I pulled the source package from zenity-proposed and pushed it to my ppa for yakkety, so you can install as follows:

sudo add-apt-repository ppa:aperomsik/aap-ppa
sudo apt-get update
sudo apt-get install emacs25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.