1

I encountered the error "Wrong type argument: number-or-marker-p" with theme-changer in a fresh Emacs 24.5 install on Windows 8.1 64-bit. I found no information about this error when searching, but reading through the issue log I found the following:

The solar package seems to get my system time/timezone which was out of sync with the location I specified in my config. Changing my timezone in ubuntu resolved it.

Basically the OS timezone and the Emacs calendar setup need to match. As my home is Detroit but I'm traveling in Europe, mine weren't even close. (By the way, 'solar.el' is included in Emacs by default in recent versions.)

0

I changed my config to the following:

(setq
 calendar-location-name "Amsterdam, NL"
 calendar-latitude 52.36
 calendar-longitude 4.90
 ;;  calendar-location-name "Detroit, MI"
 ;;  calendar-latitude       42.46
 ;;  calendar-longitude     -83.13
 )

... and theme-changer worked like a champ. I just need to remember to flip it back when I get home or find a package that will detect my location on start-up (but before I require theme-changer).

| improve this answer | |
  • For "location" detection, you can change the lat/long based on the shell env $HOST variable value. Now that won't work if you vnc/ssh into your work machine from home too :) Or probably checking IP might work but I haven't tried. – Kaushal Modi Jun 5 '15 at 13:35
  • The GeoIP idea intrigues me as an option. Unfortunately, when traveling I'm on a VPN back to the US. So the GeoIP look up would detect that and not my actual location. – prjorgensen Jun 10 '15 at 11:26
  • Would you please mark your own answer as chosen? – wasamasa Sep 3 '15 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.