2

With magit 1.4.1, I have magit-auto-revert-mode set to t. When I visit a file in a buffer, make a change and save, then call magit-status and run magit-discard-item on the modified file, then switch back to the buffer, I would expect not to see the change, ie, I'd expect the buffer to have been reverted since I discarded the change. But that's not the case. I still see the change. Is this the expected behavior or a bug?

  • The file should be reverted. When you get back to the file-visiting buffer check whether Emacs itself thinks that the file has been modified on disk - there should be an M near the beginning of the mode-line. – tarsius Jun 6 '15 at 14:01
  • Yes, the M is there. – sandinmyjoints Jun 7 '15 at 17:45
2

That's a known issue when using Magit 1.4.1 together with Emacs 24.5. It was fixed on master a few weeks ago and I have now also created a release, 1.4.2, which includes that fix.

NOTE: Magit 2.1.0 has been released, replacing the mode magit-auto-revert-mode with the option magit-revert-buffers. Like 1.4.2, 2.1.0 does not have the issue that 1.4.1. had on Emacs 24.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.