1

I'm trying to manage my passwords using the pass script from shell-mode inside Emacs. The script prompts me to enter the password twice as is customary when adding or changing passwords. The first time it asks for the password, Emacs successfully hides it, placing little dots in the message area. This is the desired behavior. Unfortunately, the second time it asks for the password, Emacs happily prints the characters to the shell-mode buffer. Is there a configuration setting I can add to make sure it hides the password both times?

1
5

Configure comint-password-prompt-regexp so that it includes whatever text pass gives at the second prompt.

Alternative answer, instead of just typing the password, you could type M-x send-invisible RET enter-the-password RET.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.