7

I had tried to create my first (private) layer for spacemacs, for the yafolding package. So I had created the ~/.emacs.d/private/yafolding/packages.el file with the following contents:

(setq yafolding-packages
    '(
      yafolding
      ))

(setq yafolding-excluded-packages '())

(defun yafolding/init-my-package ()
   "Initialize my package"
   (use-package yafolding))

And also enabled this layer in ~/.spacemacs:

dotspacemacs-configuration-layers
'(
  ;; ... 
  yafolding
  )

Now when I start emacs *Messages* lists my private layer as loaded:

Loading c:/Users/ZsBotykai/AppData/Roaming/.emacs.d/private/yafolding/packages.el (source)...done

But as far as I see, yafolding did not get installed (ls ~/.emacs.d/elpa/*yaf*).

What did I miss?

Disclaimer: as you might noticed it: I'm on Windows, with the official GNU Emacs windows binaries, although I'm having cygwin installed just in case (but without cygwin emacs). Also I had enabled other official layers but they were installed properly.

5

Instead of (defun yafolding/init-my-package () it should have been (defun yafolding/init-yafolding (), as pointed out in by cpaulik in the official support chat.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.