10

(I apologize in advance for my general technical / emacs inexperience. I use org-mode for writing novels, so have not delved very deep into its many options)

I have visual-line-mode set as my default with the line (global-visual-line-mode t) in my ~/.emacs. In the past, ctrl-k (kill-line) has killed the entire line in this mode, but on a recently reformatted computer, ctrl-k is only killing to the screen edge.

How would you suggest setting ctrl-k to kill past the screen edge again?

9

The cause of the behavior described by the original poster is the line of code from the variable visual-line-mode-map within simple.el that states: (define-key map [remap kill-line] 'kill-visual-line)

One way to reverse the process is simply removing the minor-mode key binding as follows:

 (define-key visual-line-mode-map [remap kill-line] nil)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.