3

If you look closely there is a background on the text that is different than the frame background.

Does anybody know why this happens? According to the manual (if I read it correctly) it says that they should be the same. I've tried changing the default-face but to no avail.

The theme is the moe-theme.

Dotfiles are at https://github.com/zackp30/dotfiles/blob/master/home/.emacs.d/config.org if somebody who is brave enough to try and debug them...

This also happened with the material theme.

Example of what happens

EDIT:

So, after trying the suggestions answered, I recompiled Emacs using --with-x-toolkit=lucid and the problem disappeared, so it appears to be a problem with Gtk, is there any solution for this? I found this out via the #emacs channel @ freenode. The OS is openSUSE 13.2.

EDIT 2:

Disregard the previous edit; when using Emacs as it is (as in, not as a daemon) it's fine and has the right colors), but when I am using it as a daemon it has the issue displayed previously. Very very weird...

EDIT 3:

Gah! Forgot about the fact that I reproduced it in an X11 window, with emacs -Q without using the daemon. I'll be submitting an Emacs bug.

  • The daemon loads up settings from files like ~/.Xresources, so that may be one source of unwanted customizations if you've got a wildcard item matching one of Emacs' X resources. I've spotted an included file for solarized colors without prefixes in your dotfiles, try commenting out the import for it in your ~/.Xresources. – wasamasa Jun 23 '15 at 18:28
1

Possibly a duplicate of this question.

The answers there should help you with this.

First, start from emacs -Q (no init file). Do whatever you need to do (e.g. load the theme) to repro the problem, but without doing all the rest of what might be in your init file.

Then check the face(s) used on the text in question, using C-u C-x =. Check the face's background. Check the background of face default, which is used for the non-text areas of the frame. If they are not the same, just customize one or the other face, so that it has the same background as the other.

The frame background is the background of face default. It is also the value of frame parameter background-color. You can customize either face default or option default-frame-alist (parameter background-color), to fit your theme or whatever.

|improve this answer|||||
  • Thanks! I tried this to no avail, it seems to be a problem with Gtk itself (a theme somewhere?). See latest edit. – Xack Jun 23 '15 at 18:17
  • Maybe that bug is relevant for the ~duplicate question as well. Is this the bug you reported? If not, what bug number? – Drew Jun 24 '15 at 0:55
  • That is not the bug I reported, no. It seems to be the same problem I'm experiencing. I shall head over to that bug report. – Xack Jun 24 '15 at 8:00
  • Thanks. If you are both using a recent development snapshot then that might explain the problem - something might have been broken recently. Be sure to provide the info about your build to the bug thread. You can see that info by using M-x report-emacs-bug: it is automatically added to the message buffer that you prepare. (No need to send a separate bug report, but you can copy that build info and send that to the existing bug thread, if it is for a development snapshot build.) – Drew Jun 24 '15 at 13:35
1

You can get information by placing the cursor on a character of the type you want information about, just like in your picture, and then type M-x describe-char. You will then get a buffer, with among other things the name of the face of the character, through the entry font-lock-face. Following that link will take you to the definition of the face, where the background might have been set.

If there is no font-lock-face entry, the character is likely in the default face. M-x describe-face and then selecting default should give you the properties of that.

|improve this answer|||||
  • Weird, there's no entry font-lock-face, I also ran emacs with emacs -Q, and required package, installed moe-theme, and ran (moe-dark), and the issue still happens and font-lock-face still isn't there. Even with another theme (material-theme) it's still there. If it helps I use VNC to a Linux system when on windows machines, but the screenshot was taken server-side using a Linux screenshot tool, not using the windows machine... This is very strange... Another thing: I'm using the latest Emacs master, but this has been happening for a while... weird. – Xack Jun 23 '15 at 12:51
  • You are right, added a section on that. – Meaningful Username Jun 23 '15 at 14:46
  • Thanks! I still have the problem, it seems to be a problem with Gtk. See latest edit. – Xack Jun 23 '15 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.