helm seems to implicitly insert the current symbol at point as an initial query.

enter image description here

(For reference, this is helm-omni from here)

Note how the minibuffer is empty, yet helm is already searching for idle-require.

This has some performance implications that I'd like to avoid. Is there any way I can turn this behavior off?

(Probably will require advice, as Helm's author says he doesn't want to add an option to turn it off).

There has been a lot of interest in this (but nothing's come of it yet):

  • The screenshot looks a bit like swiper, which doesn't have the deficiency that you mention. And lispy-goto works better than imenu for Elisp.
    – abo-abo
    Jun 23, 2015 at 16:30
  • @abo-abo Indeed. But it's called helm-omni for a reason. It does everything: files, buffers, lines, ag, find, locate, git etc.. The function automatically builds the helm based on context information (i.e. am I in a project?). It works really well... except when the ffap-like behavior jumps up and gets in the way.
    – PythonNut
    Jun 23, 2015 at 16:52
  • I see. No wonder you try to make it work:)
    – abo-abo
    Jun 23, 2015 at 16:53
  • You should probably link to the definition of helm-omni from stackoverflow.com/a/19284509/821010 or wherever in the question... although with that version of my-helm-omni I'm not able to reproduce the issue you described. Jun 23, 2015 at 21:35
  • @JoeCorneli ah thanks. It didn't occur to me that this could be function specific. It looks like this has something to do with helm-source-find-files, which is in my latest omni, but not that one.
    – PythonNut
    Jun 23, 2015 at 22:43

1 Answer 1


Some sources used by you like helm-source-imenu and helm-source-occur are in the helm-sources-using-default-as-input list, so helm will build result initially, so setting that list to nil temporarily should work, for example

(let ((helm-sources-using-default-as-input nil))
  (helm ...))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.