6

I'm using using AUCTeX to write a IEEEtrans LaTeX document with a seperate BibTeX file.

As I recall I used to simply hit C-c C-c (currently bound to TeX-command-master) repeatedly until it said "view" in the minibuffer, and then AUCTeX would have taken care of running pdflatex and bibtex as needed.

I've now moved to a new machine - Still same OS (Linux Mint 17.1) and same ~/.emacs (I keep it on github, but rely on el-get for e.g. AUCTeX)

To my surprise AUCTeX doesn't pick up changes in bibtex file, but simply runs LaTeX and then View. Any suggestions as to why it doesn't realize the need to run BibTeX?

Some details: (Please ask if you need more)

  • OS: Linux Mint 17.1 x64_64
  • Emacs: GNU Emacs 24.3.1, from apt-get
  • AUCTeX: from el-get, tag: release_11_88, commit: 5178ba6

Files, after Clean All:

.
├── bib
│   └── paper.bib
└── paper.tex

Files if I call LaTeX, BibTex, LaTeX, LaTeX:

.
├── bib
│   └── paper.bib
├── paper.aux
├── paper.bbl
├── paper.blg
├── paper.log
├── paper.pdf
└── paper.tex

Contents of paper.tex:

\documentclass[conference]{IEEEtran}
\begin{document}
\cite{ref}
\bibliographystyle{IEEEtran}
\bibliography{IEEEabrv,bib/paper}
\end{document}

%%% Local Variables:
%%% mode: latex
%%% TeX-master: t
%%% End:

Contents of bib/paper.bib:

@electronic{ref,
  author        = "Someone",
  title         = "Sometitle",
  url           = "http://test.com",
  year          = "2000"
}
  • Auctex will only call bibtex if it detects a bibliography command in your latex file. What bib command do you use? – Malabarba Jun 25 '15 at 12:00
  • @Malabarba I use these: \bibliographystyle{IEEEtran} and \bibliography{IEEEabrv,bib/paper} (Question updated) – kidmose Jun 25 '15 at 13:35
  • Could you please provide a concrete minimal working example? Guessing what you really have in your document is pretty hard. – giordano Jun 26 '15 at 13:30
  • Works for me. As a general rule, avoid using bibtex file and tex file with the same base name, AUCTeX isn't very smart in this case. – giordano Jul 1 '15 at 12:10
  • have you tried install auctex via ELPA? I was having problems with (apt-get) auctex and emacs 24 that stopped when I changed to emacs packaged installation directions here! – Yair Jul 1 '15 at 12:27
5

Based on advised from Mosè Giordano on the AUCTeX mailing list I've found that putting the below snippet from AUCTeX Manual in my .emacs.d fixes the problem:

(setq TeX-parse-self t) ; Enable parse on load.
(setq TeX-auto-save t) ; Enable parse on save.

This is the intended behavior, see thread on AUCTeX mailing list

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.