In Magit buffers, or helm-swoop, an unclosed double quote enables the string highlighting for the rest of the buffer (until another quote is found). This is how it looks like:

enter image description here

Because of that, I also lose the green/red highlighting of added/removed lines in Magit. When I disable the font-lock-mode, everything becomes fine (blue text is not blue anymore, +/- lines are colored).

I could add hooks to disable font-lock-mode in those buffers but it is too much trouble to do that for every buffer. Can I somehow find out what causes the screwup in the first place?

1 Answer 1


It turned out that I created a problem myself. I unconditionally enabled rainbow-mode in all buffers, which sets the font-lock-keywords variable.

To discover this I debugged the font-lock-specified-p function which returned t in Magit mode (and it shouldn't). Hope this information helps someone.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.