I recently updated magit from melpa. It seems that it requires Emacs 24.4. Since I had 24.3, I've also updated Emacs to 24.5.

When I do M-x magit-status and choose the directory with .git, it asks me if I want to create repository in that directory. I say no, and nothing happens. It seems that magit thinks that the directory isn't a git repository. If I say yes, it produces wrong number of arguments error.

I waited for the next magit update, this issue still hasn't fixed for me. Should I go back to a stable version?

M-x magit-version says Magit 20150707.1446, Git, Emacs 24.5.1

1 Answer 1


That problem is symptomatic of using Magit 2.x with an old Git version (certainly with Git 1.7).

You'll need to upgrade Git (at present version 1.9.4 or later is required), or else downgrade Magit.

See also Updating from an older release:

Also note that starting with the 2.1.0 release, Magit requires at least Emacs 24.4 and Git 1.9.4. You should make sure you have at least these releases installed before updating Magit. And if you connect to remote hosts using Tramp, then you should also make sure to install a recent enough Git version on these hosts.

  • Since that fixes the issue, you should accept it, even though it was you yourself who provided it :-)
    – tarsius
    Jul 11, 2015 at 11:57
  • Thank you. I did these to fix the issue. * Upgrade Debian from Wheezy to Jessie (because lots of packages were outdated) * Upgraded Emacs to 24.5.1, Git to 2.1.4 * Removed git-commit (?) or some other Emacs packages completely * Remove and reinstall magit
    – Jaehyun
    Jul 22, 2015 at 17:53
  • For anyone in a similar situation, upgrading the entire OS isn't a requirement! You can most likely find alternative package sources for newer version of Emacs and Git; and if not, then compiling them from source is always an option. Unless you were looking for an excuse to upgrade your OS, you don't need to do that just to use Magit 2.
    – phils
    Jul 22, 2015 at 21:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.