1

I just upgraded to a new bleeding edge version of Emacs in OS X:

brew install emacs --HEAD --use-git-head --with-cocoa 
--with-gnutls --with-rsvg --with-imagemagick

I understand that this version is not stable and that I shouldn't expect it to wok without any problems. Still, my experience so far has been relatively positive installing from HEAD directly.

For some reason, after today's update, I now run into this warning when I start Emacs. I am hoping to debug this problem using setq debug-on-message as suggested in many threads without luck.

I tried adding (setq debug-on-message "Warning (bytecomp)") or (setq debug-on-message "Warning \(bytecomp\)") at the beginning of my .emacs file and starting Emacs with emacs --debug-init, but I don't see any trace either in the Compile-Log or the Messages log.

I have also tried re-compiling all packages from scratch, as explained in this answer, i.e. doing M-: (byte-recompile-directory package-user-dir nil 'force), but the problem persists.

How can I effectively debug this type of warning?

  • Not an answer, but if you don't want random error messages, random errors, or even random crashes. I would not suggest you use the bleeding edge development version. – Jordon Biondo Jul 14 '15 at 20:57
  • 1
    You haven't actually stated how you get that warning. I assume it happens at startup? – Malabarba Jul 14 '15 at 22:07
  • Show the complete warning message here. Presumably it mentions a particular variable or a particular function where the variable seems to be free. If the latter, try using (debug-on-entry 'THE-FUNCTION) in your init file, and step through the debugger to see what goes on. Or grep for the variable or function name to see what library uses it and how. You should not need to recompile anything. IOW, it's standard needle-in-haystack debugging, if you really care to see what's going on. – Drew Jul 15 '15 at 1:22
  • bughunter also fails to reproduce these warnings, meaning that it cannot be used to bisect the configuration. – Matthew Piziak Aug 7 '18 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.