2

I have an issue with Aquamacs. When press something like C-c a t (= org-todo-list in org-mode) the minibuffer shows an error message that there is no keybinding for ^C A, despite Shift is neither pressed nor locked. I tried this with various other keybindings, yet to no avail.

Any ideas?

  • What's the exact message you get when you do C-h k C-c a? – Kaushal Modi Jul 16 '15 at 10:43
  • On pressing C-h k I am asked to Describe key (or click or menu item):, and when I then press C-c a the same error message appears: ^C A is undefined. – Singulaere Entitaet Jul 16 '15 at 11:45
  • I don't use Mac so couldn't help more other than asking you to verify if you see the same problem in an emacs -Q session. Launch emacs -Q, bind C-c a to org-agenda and then do C-h k C-c a. – Kaushal Modi Jul 16 '15 at 13:46
  • Can you please paste in your question the exact and complete buffer contents when you do C-h k C-c a? You using ^C A looks very strange to me. Emacs should be reporting C-a or C-S-a as far as I know. – Kaushal Modi Jul 16 '15 at 14:17
  • Well, the buffer is empty: I opened a fresh new "Untitled" buffer and started org-mode. When I press C-h, the minibuffer shows ^C H (that is with a capital H), I then told to enter a letter or ? for a list of options in the minibuffer. If I press C-c a the same error message appears as mentioned in my question. – Singulaere Entitaet Jul 16 '15 at 14:50
1

The key binding is not set-up by default, it is a just a recommendation from org-mode. You need to add something like

(global-set-key "\C-ca" 'org-agenda)

to your init file, or Preferences.el for Aquamacs. In my init file I have

(global-set-key "\C-cl" 'org-store-link)
(global-set-key "\C-ca" 'org-agenda)
(global-set-key "\C-cb" 'org-iswitchb)
(global-set-key "\C-cc" 'org-capture)

Part of the reason for this is that C-c sequences are meant to be reserved for user defined short cuts. Without these definitions you can always type for example M-x org-agenda to run the agenda command.

  • I am confused why he is emphasizing that emacs reports the binding as ^C A with uppercase A. It's also strange to read ^C A instead of C-S-a or C-a. I don't think emacs would ever report C-S-a binding as C-A. – Kaushal Modi Jul 16 '15 at 14:15
  • @AndrewSwann: that would be quite annoying, considering the hundreds of keybindings explained in detail in the manual, which I even bought in print. Moreover, I am pretty sure I tried the agenda view some days before, and the keybinding worked at that time. I installed Aquamacs plain vanilla and didn't tinker with any of its configuration files. – Singulaere Entitaet Jul 16 '15 at 14:57
  • @SingulaereEntitaet C-c a has to be bound by the user. Based on our discussion in the comments, implementing Andrew's solution should fix your problem. As per Activation - Org Manual, C-c a is a suggested binding; user can bind as suggested if they wish. Emacs cannot ship with pre-bound C-c SINGLE-LETTER bindings. – Kaushal Modi Jul 16 '15 at 15:00
  • I stand corrected, @kaushalmodi. – Singulaere Entitaet Jul 16 '15 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.