2

I've bound cmd-P in emacs to some function. It is working in emacs when I start the cocoa version but I can't make it work in console mode when running in iterm.

I made iTerm2 ignore the keystroke in Preferences->Profile->Default->Keys and it is no longer user by iTerm but looks like emacs in console is ignoring command key completely.

Is there any way to use console mode emacs in OsX using command as super?

  • 1
    Is this a question about iterm2, or about Emacs? And have you already confirmed that it's not covered by Problems with keybindings when using terminal? You might try (unless (display-graphic-p) (setf ns-command-modifier 'super)). (Note: I haven't tested this.) – Dan Jul 17 '15 at 14:56
  • You are probably right. After reading the post you liked looks like it is iTerm not sending the keystroke to emacs in terminal. Thanks a lot, really, for the guidance. – Rafa de Castro Jul 31 '15 at 7:28
2

Unfortunately, this cannot be done in either iTerm2 or Terminal, due to limitations in the terminal interface. You can bind Command to meta, but if you want a setup that allows you to use option for meta and Command for super, you have to use GUI Emacs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.