3

Let's face it, the scroll bars for the graphical emacs are both ugly and, if you're sufficiently experienced, entirely unnecessary. Here's a picture of terminal emacs (which uses the | character to separate horizontally aligned buffers) adjacent to the graphical emacs on OS X (which *shudder* uses scroll bars:

enter image description here

My question is this: how can I get the graphical emacs to look more like the terminal emacs and eliminate the scroll bars? I don't need it to look exactly the same, but something closer than what I've got now would be rather nice.

Oh, I should also point out that simply using (scroll-bar-mode -1) leaves me with an empty space where the scroll bar used to be, which I don't like. I still like to be able to see where one buffer ends and the other begins.

5
  • Turn off the fringe, which is probably what that empty space is.
    – Dan
    Jul 17, 2015 at 0:08
  • 1
    It might be an OSX issue? For both the GTK3 and Lucid X Window toolkits on Linux, disabling scroll-bar-mode leaves me with something fairly akin to the terminal: just a thin vertical line in place of the scroll bar, which is only padded by the fringes. (Emacs 24.4 & 24.5)
    – phils
    Jul 17, 2015 at 0:23
  • 1
    I've got it on both Linux and OS X with no scroll bars, and it looks like the terminal line. I turned off my fringe, but you could also change the fringe's face to match the background.
    – Dan
    Jul 17, 2015 at 0:46
  • Ah...it turns out that this was a consequence of my theme. Problem solved. Thanks all!
    – GJStein
    Jul 17, 2015 at 0:49
  • 1
    Please post an answer and select it after the obligatory waiting period. It may help someone else in the future.
    – Dan
    Jul 17, 2015 at 1:13

3 Answers 3

4

Turn off scroll bars and customize option default-frame-alist to specify whatever you want for parameterright-divider-width (and perhaps parameter bottom-divider-width).

0

As it would turn out, my theme (the spolsky-theme from the sublime-themes package) made this vertical line disappear when the scroll bar was disabled. By changing to another theme (from the color-theme-solarized package), the vertical bar reappears.

Problem solved.

0
0

In spolsky-theme.el, you can edit the line

`(vertical-border ((t (:foreground, *background*))))

to use another color than that of background (which is #161A1F; also used for window background). Note that the fringe background also use the same color, so only changing the vertical-border to a constrasting color (e.g. silver, #C0C0C0) gives quite a clean minimal dividing line, as the fringe can not be differentiated from the background.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.