6

I can M-x projectile-mode (I get this and other projectile commands in the completion list) but it fails with

Autoloading failed to define function projectile-mode

Projectile is an installed package, according to package-list-packages:

projectile 20150724.1312 installed

(And I can use C-h f to search for the function and to open the projectile.el file.)

When I add (require 'projectile) to my init.el, startup fails with

error: Required feature `projectile' was not provided

Emacs 24.5 on OSX installed via Homebrew, using the Emacs Live (git rev 170bddd, 2015-07-18) setup. Here is my Emacs config (as an Emacs Live pack).

Any help would be appreciated. Thank you!

  • So re-installing projectile fixed it - but on the next start, the problem was back :-( No other package has this issue. – Jakub Holý Jul 28 '15 at 9:01
  • 2
    Do you have (package-initialize) in your init? – Kaushal Modi Jul 28 '15 at 11:17
  • Yes, I do - you can see my init.el here – Jakub Holý Aug 4 '15 at 9:06
6

You got the error "Autoloading failed to define function" because multiple packages are apparently active in your load-path. Try M-x list-load-path-shadows to get a clue which packages are conflicting.

  • 2
    From the list... how do we know whats wrong? I have 151 lisp load-path shadowings – Pedro Luz Sep 28 '17 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.