1

I have a remote server I log in to from the command line using either:

ssh 'GROUP\user'@host.edu 

or

ssh GROUP\\user@host.edu

and it works fine; I've even set up my SSH keys. But I can't figure out how to get this to work with tramp, as the "\" gets sanitized. I've tried using quotes and/or escape slashes, but those don't make it through either. Any solutions?

  • Please show exactly what you tried. – phils Mar 11 '18 at 1:54
1

I found the solution by using ssh_config, which allows you to bypass all concern about escaping; you just enter your login name in your ~/.ssh/config file and tramp will respect it. I posted full details here: http://www.toryanderson.com/tech/escaped-log-ins-tramp

0

The link in the accepted answer doesn't work anymore.

A workaround for this issue is to specify only the hostname; tramp will then prompt for the username (and password).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.