3

I'm seeing interesting behavior when I try to copy text between other applications and emacs on arch linux, when using evil-mode.

Whenever I have a region selected in emacs, and then click to focus chrome, the region selected is my clipboards contents. I actually only want my region copy'd to my clipboard when I yank.

Also whenever I copy text in chrome, and then focus my emacs window, If I already have a region selected in emacs, that region is now what evil-paste-after produces. I expect my copied text from chrome to be pasted, not the region I happen to have selected. If I have no visually selected region in emacs, then then my next evil-paste-after is actually my copy from chrome.

I've seen others remark about mouse-drag-copy-region and have the line (setq mouse-drag-copy-region nil) set in my config. This setting seemingly works for me when I'm not using evil-mode. But with evil-mode enabled, my mouse selections end up copying to the clipboard.

I believe this answer may solve my issue if I can alter it to be for my platform, instead of OSX

These questions also may be related

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.