0

When I relaunched emacs after updating some packages, I had an error:

Debugger entered--Lisp error: (file-already-exists "File already exists "/home/linevich/.emacs.d/elpa-24-3-1-x86-64-pc-linux-gnu/list-utils-20140508.1341/list-utils-pkg.el")
  write-region("(define-package \"list-utils\" \"20140508.1341\" \"List-manipulation utility functions\" (quote nil))\n" nil "/home/linevich/.emacs.d/elpa-24-3-1-x86-64-pc-linux-gnu/list-utils-20140508.1341/list-utils-pkg.el" nil nil nil excl)
  package-unpack-single("list-utils" "20140508.1341" "List-manipulation utility functions" nil)
  package-download-single(list-utils "20140508.1341" "List-manipulation utility functions" nil)
  package-download-transaction((ucs-utils list-utils pcache persistent-soft font-utils unicode-fonts))
  package-install(unicode-fonts)
  ergoemacs-component-struct--ensure(unicode-fonts)
  ergoemacs-component-struct--apply-inits()
  run-hooks(ergoemacs-mode-startup-hook)
  ergoemacs-mode(1)
  eval-buffer(#<buffer  *load*> nil "/home/linevich/.emacs.d/init.el" nil t)  ; Reading at buffer position 524
  load-with-code-conversion("/home/linevich/.emacs.d/init.el" "/home/linevich/.emacs.d/init.el" t t)
  load("/home/linevich/.emacs.d/init" t t)
  #[0 "\205\262

I tried to remove this file, and had the next one traceback:

Debugger entered--Lisp error: (file-already-exists "Файл вже існує" "/home/linevich/.emacs.d/elpa-24-3-1-x86-64-pc-linux-gnu/pcache-20150125.1653/pcache-pkg.el")
  write-region("(define-package \"pcache\" \"20150125.1653\" \"persistent caching for Emacs\" (quote ((eieio \"1.3\"))))\n" nil "/home/linevich/.emacs.d/elpa-24-3-1-x86-64-pc-linux-gnu/pcache-20150125.1653/pcache-pkg.el" nil nil nil excl)
  package-unpack-single("pcache" "20150125.1653" "persistent caching for Emacs" ((eieio (1 3))))
  package-download-single(pcache "20150125.1653" "persistent caching for Emacs" ((eieio (1 3))))
  package-download-transaction((ucs-utils list-utils pcache persistent-soft font-utils unicode-fonts))
  package-install(unicode-fonts)
  ergoemacs-component-struct--ensure(unicode-fonts)
  ergoemacs-component-struct--apply-inits()
  run-hooks(ergoemacs-mode-startup-hook)
  ergoemacs-mode(1)
  eval-buffer(#<buffer  *load*> nil "/home/linevich/.emacs.d/init.el" nil t)  ; Reading at buffer position 524
  load-with-code-conversion("/home/linevich/.emacs.d/init.el" "/home/linevich/.emacs.d/init.el" t t)
  load("/home/linevich/.emacs.d/init" t t)
  #[0 "\205\262

When I removed this file too, I had the same error as at the beginning "list-utils-pkg.el" exists.
How to fix this?
My config is messy, but I think that the problematic package is ergoemacs which tries to install some packages.
Config here.
P.S Sorry for my English :)

3
  • Have you tried contacting erogemacs with the error message? Xah Lee usually finds workarounds if you can provide debugger messages.
    – Emacs User
    Aug 6 '15 at 23:29
  • Thanks for advice, I've already done it. issue Aug 7 '15 at 10:07
  • One last suggestion, a while back something similar happened and I had to delete the offending packages and reinstall them so old code got cleaned out. Later I found out it was related to math fonts. Perhaps you can try cleaning out while you wait for ergoemacs to respond.
    – Emacs User
    Aug 7 '15 at 15:13
0

I found the solution on GitHub:

This seems like a package management issue. I would delete the elpa versions of ergoemacs-mode and list-utils and then use the stable melpa repository. This require updating your config to:

(add-to-list 'package-archives ;'("melpa" . "http://melpa.milkbox.net/packages/") '("melpa-stable" . "http://stable.melpa.org/packages/") '("marmalade" ."http://marmalade-repo.org/packages/") )

Then re-downloading the stable ergoemacs-mode.

1
  • Please summarize the answer. Link-only answers are typically closed.
    – Drew
    Aug 9 '15 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.