2

I have my ido-ignore-directories set to the standard value:

("\\`CVS/" "\\`\\.\\./" "\\`\\./")

The third regexp, "\`\./" should ignore the current directory, as near as I can tell. However, it doesn't:

Find file read only: ~/{. | Desktop/ | Documents/ | ...}

If it matters, I have C-x C-f bound to ido-find-file-read-only. This is with emacs 24.3.1. How do I fix it?

  • 1
    Dunno (I don't use Ido), but you will notice that Ido shows ., not ./, whereas it shows Desktop/. Whether that is just inconsistent output on the part of Ido, or whether you need to explicitly match . in addition to ./, I don't know. You are currently matching explicitly against the /, and the candidate shown by Ido is . - no slash. – Drew Aug 7 '15 at 21:42
3

Drew's comment inspired me to look closer at ido's settings. Turns out there's an ido-show-dot-for-dired setting that will always put . as the first element in the completion list so you can quickly do a dired on the directory. I, unbeknownst to me, had that set to t instead of nil. This is what I get for starting with someone else's .emacs file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.