1

How should one indent text in org-mode with org-indent-mode disabled? I expect something like this:

* A
  Some text.
  - item 1
  - item 2

** B
   More text.

EDIT: This seems to depend on the variable org-adapt-indentation. I have it set to t.

Incorrect indentation of babel output

But then this output of the evaluation below (using org-babel) is incorrectly indented:

* Headline showing result indentation

  Some text aligned with the headline.
  Evaluate lisp expression ~(require 'ob-python)~ and then run the code
  block below.

  #+BEGIN_SRC python :results output
    for i in range(10):
        print(str(i))
  #+END_SRC

  #+RESULTS:
  #+begin_example
  0
  1
  2
  3
  4
  5
  6
  7
  8
  9
#+end_example

  After running the output on the previous line is incorrectly indented.

How do can I use org-mode in such a way that evaluated output (more than 10 lines long) is correctly indented? I suspect there is an option to fix this or, if not, this may be a bug but my experience with emacs and org-mode is limited. I used emacs 24.5.1 with the -q option and an empty home directory just to make sure it is not a misconfiguration.

  • My understanding is that you should not manually indent (add physical spaces) blocks/sections in org-mode. org-indent-mode is to make this default non-indented format more visually pleasing. – Kaushal Modi Aug 13 '15 at 12:15
  • I considered that possibility, but came to the conclusion that not indenting the text is not the default behaviour. When using M-right and M-left the indentation is added automatically (at least in org 8.3 by default) when not in org-indent-mode. Also deadline and notes are indented by default to match the headline level. – Araeos Aug 13 '15 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.