5

On Emacs (Mac) I have saved a desktop which opens two .org files (one of this has an image - jpg) and whenever I open up Emacs, I have to always type y to:

display /route/to/image/Logo.jpg? (y or n)

How can I make y the default? Haven't found a way to do it, so here I am.

Thanks in advance.

  • 1
    Have you already tried?: (setq org-startup-with-inline-images t) This can also be done on a per file basis: orgmode.org/manual/In_002dbuffer-settings.html – lawlist Aug 15 '15 at 5:21
  • You also might want to check this out. – Luke Aug 15 '15 at 14:47
  • @lawlist Thank you! I'm new on this site, don't know how to set you as the correct answer. – fillipvt Aug 15 '15 at 14:51
  • You can't mark it as correct unless @lawlist reposts it as an answer instead of a comment.. Then you can upvote it and check the "accepted" button to mark it as correct. – erikstokes Aug 15 '15 at 16:19
4

The variable org-startup-with-inline-images can be set globally with the following in the .emacs or init.el file [the default value is nil] -- Non-nil means show inline images when loading a new Org file.:

(setq org-startup-with-inline-images t)

or, it can be set locally as described in the doc-string: This can also be configured on a per-file basis by adding one of the following lines anywhere in the buffer:

#+STARTUP: inlineimages
#+STARTUP: noinlineimages

Here is a link to the manual on this subject: http://orgmode.org/manual/In_002dbuffer-settings.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.