3

I want to set a different font for org-mode contents. Strangely, setting

'(org-level-1 ((t (:inherit variable-pitch))))

has the effect on headers as intended. However, setting

'(org-default ((t (:inherit variable-pitch))))

does not impact the text on normal org-mode text. They're still fixed-width font.

If I run describe-face on those text, it just says default instead of org-default. Not sure if that's the normal behavior.

How can I manually set font for normal org-mode content text?

  • It looks like the answer is on the mailing list -- i.e., buffer-face-mode needs to be enabled for buffer-local face settings such as changing the 'default: comments.gmane.org/gmane.emacs.orgmode/84250 – lawlist Aug 18 '15 at 3:44
  • @lawlist That worked. Unfortunately it seems to turn everything within org-mode into variable-pitch... not only the normal texts. – xji Aug 18 '15 at 4:01
  • @lawlist the OP is correct, buffer-face-mode changes all faces – Richard Border Jan 17 '17 at 21:30
  • Why not use variable-pitch-mode for this? (add-hook 'org-mode-hook (lambda () (variable-pitch-mode t))) – Timm Jan 17 '17 at 22:18
  • @RichardBorder Actually I even forgot I asked this question. I already found a solution to what I need by using a combination of `variable-pitch-mode and customized face settings. You can see the related questions at stackoverflow.com/a/16819449/1460448 and emacs.stackexchange.com/questions/14824/… – xji Jan 18 '17 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.