2

I am not a fan of the way AUCTeX indent LaTeX code. Some time ago I asked for help in disabling indentation.

The solution provided there handles the large majority of my needs, but fails to prevent indentation of text inside brackets, such as for \footnote{text} or \textbf{something bold}. More specifically, if I have some text like this

Here is a paragraph which you should 
pretend\footnote{some stuff} has much
longer lines.

and then fill the paragraph, I often get something like the following

Here is a paragraph which you 
should pretend\footnote{some
  stuff} has much longer
lines.

I don't like the way the contents of the \footnote command are indented. Is there a simple way to disable this?

4

Reading the manual often helps: this is controlled by TeX-brace-indent-level.

User Option: TeX-brace-indent-level

Number of spaces to add to the indentation for each { not matched by a }.

Set it to 0 in your init file:

(setq TeX-brace-indent-level 0)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.