1

I'm trying a new custom theme, but it only seems to be partly applied as the background isn't appearing. I'm very, very new to Emacs, so would appreciate advice on how to fix it.

I'm using GNU Emacs 24.4.1 (x86_64-pc-linux-gnu, GTK+ Version 3.14.9) of 2015-03-21 on kissel, modified by Debian. Ubuntu 15.04 Called from the GUI, not the terminal. I'm also using the most recent version of Emacs live

My init.el is here

  • what happens if you switch to the scratch buffer, then enter (dolist (i custom-enabled-themes) (disable-theme i)), move after the last parenthesis and evaluate the expression C-x C-e ? – martin Aug 30 '15 at 8:14
  • It displays nil in the minibuffer. Afterwards, if I do M-x load-theme white-sands, it doesn't change the background color. – user619882 Aug 30 '15 at 8:51
  • 1
    You should start Emacs with -Q flag, then evaluate (package-initialize) (as @severin described) then evaluate (load-theme 'white-sand-theme t). Then tell us if it worked OK. – Mark Karpov Aug 30 '15 at 9:54
  • I started emacs -Q and ran the following in scratch (dolist (i custom-enabled-themes) (disable-theme i)) (setq package-archives '(("gnu" . "http://elpa.gnu.org/packages/") ("melpa" . "http://melpa.milkbox.net/packages/"))) (package-initialize) (package-install 'white-sand-theme) (load-theme 'white-sand) and it successfully displayed the theme. – user619882 Aug 30 '15 at 20:51
0

Apparently some setting in your Emacs Live setup overrides the loaded theme's background-color.

As you are a new to Emacs, I heartily recommend that you start with an empty init file and go from there.

Not because those starter kits are bad, some are in fact rather beautiful, but it's much harder to troubleshoot problems in some big starter kit, than if you start with a clean init.el and gradually add stuff. If things stop working then, you know exactly what you did, and you can easily revert those changes.

Without knowing for what you are using Emacs, a minimal emacs setup could look like this:

An empty folder ~/.emacs.d

This folder contains the file init.el with the following contents:

(require 'package)
(setq package-enable-at-startup nil)
(add-to-list 'package-archives '("melpa" . "http://melpa.org/packages/"))

(package-initialize)

This enables the melpa package archive.

Now you have access to ~2.500 packages, among them gems like magit, use-package, paredit, flycheck, company, expand-region, avy, ... .

| improve this answer | |
  • Thanks. You're right. I'll switch away from overtone.github.io/emacs-live for the moment and get used some more simple changes. (I used emacs-live as I wanted to learn Overtone, which is also by Sam Aaron.) – user619882 Sep 1 '15 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.