0

Here is the error when semantic by default add wisent-python-default-setup into hook python-mode-hook. It's shown in minibuffer.

Makeing python-shell-interpreter-args local to Python Internal[ org-src-fontification:python-mode] while let-bound!

It happens when I open Org-buffer with Babel Python code block, and python source code file.

I found relative issue here:

Then I try to remove this from hook by the following code:

(remove-hook 'python-mode-hook 'wisent-python-default-setup)

But this does not work, after Emacs finished start, I check out python-mode-hook, it's still over there.

I guess maybe semantic is enabled after my upper "removing it from hook". But I don't know when and where. (Maybe someone can tell me how to debug it)

  • That's just a warning. Might result in a bug sometimes, but must not. Probably you may ignore this. – Andreas Röhler Sep 1 '15 at 5:30
  • I don't know what caused Emacs suspend, but when this message appears, then Emacs suspend, so I want to disable it, maybe I need to disable the whole semantic? – stardiviner Sep 1 '15 at 6:01
  • And consider a bug-report? – Andreas Röhler Sep 1 '15 at 6:33
  • I don't think it's a bug, could be semantic enabled after my remove hook, so it is added again. I don't know where, and how to find it out. – stardiviner Sep 1 '15 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.