1

I asked this questions on Github I have just switched form auto-complete mode to company mode, but the error message

Warning (emacs): Unable to activate package jedi'. Required packageauto-complete->1.4' is unavailable

pops out. Do I have to install "auto-complete" (even I don't use it) to activate jedi?

2

You need to uninstall jedi and install company-jedi.

  • Thanks, but in this case ,may I still use jedi as the library, or the package "jedi-core" and "company-jedi" is enough? Do I have to uninstall jedi from pip? – MagisDing Sep 7 '15 at 14:03
  • Sorry, I have no idea about that. If you find documentation for these projects insufficient, you can file an issue about that. – Dmitry Sep 7 '15 at 17:07
0

Do not use Jedi. Use anaconda-mode. Jedi not work with company-mode and work with errors in company-jedi (or I can't configure it).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.