1

I have been trying to use visual-regexp-steroids without luck (a thread on this package can be found here)

When I do vr/replace (C-c p), I get a prompt in the minibuffer. I can enter regexps and Emacs shows interactively every match in the buffer. So far so good.

The problem comes when I click RET and then enter another string (the one I want to replace my matches with). If I now do RET (to do the actual replacements), I get the following message in the mini-buffer:

Args out of range #<killed buffer>, 0, 0

Why? How can I debug the problem and get it to work?


  • Update: I have opened an issue in the GitHub repository here
  • How is this related to multiple cursors? To debug the error, do M-x toggle-debug-on-error and then recreate the error. You can then paste the generated backtrace info in your question above to help people further assist you. – Kaushal Modi Sep 9 '15 at 12:46
  • 1
    It doesn't sound like you're doing anything wrong. I think I'd file an issue on github – Malabarba Sep 9 '15 at 12:49
  • You are right @kaushalmodi This specific vr command is not about multiple-cursors. I removed the tag. – Amelio Vazquez-Reina Sep 9 '15 at 12:50
  • Sounds like you should file a bug with the maintainer (and then delete this question). – Drew Sep 9 '15 at 13:37
1

The problem was that my shell init file (.zshenv in my case, since I am using zsh) was printing one line to stdout every time I logged in, and this was confusing the parsing. Once I removed the echo line, everything worked well.

I am leaving this as an answer here in case anyone else runs into the same problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.