3

I am trying to stage few hunks of a file using magit.

My point is on first hunk like this

enter image description here

Now if I press s to stage this hunk, it will stage hunk and moves point back to file like this

enter image description here

Now to stage next hunk, again I have to move point to hunk and press s.

Instead of this, if magit can retain point position, it will be much easier for me to stage hunks very easily.

If I remember correctly old magit versions (1.x) had this desired behavior? How can I get back that behavior?

3
  • 1
    There's no option to enable this behavior, Magit should just always do that. Please open a feature request instead. Or really, you can also just wait a day or two - this should be easy, and I probably won't forget to do it.
    – tarsius
    Sep 16, 2015 at 18:59
  • 1
    @tarsius Post bug fix as answer? Sep 17, 2015 at 15:59
  • It's probably best to just delete this issue. (Do I actually have to mention your name or are you notified even if I don't do that?)
    – tarsius
    Sep 17, 2015 at 16:08

1 Answer 1

3

Magit should always do that by default.

There was a bug in magit and it was fixed in this commit by @tarsius

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.